Journal du Nazmi

Une petite archive de mes prises de tête techniques et sociétales

Installer Mumble 1.3 (la version 2019 du futur) sur Debian 9

Temps de lecture : 2 minutes

Voici un petit hack qui vous permettra d'avoir la nouvelle version de mumble sur Debian 9 Stretch (les dépôts donnent la 1.2.18 et il faudrait passer à Debian 10 pour avoir le nouveau mumble d'officiellement supporté).

Avec mumble 1.3.0-1 vous pouvez désormais:

-bénéficier d'une nouvelle interface plus classe et d'un thème sombre

-baisser le volume d'un copain un peu bruyant

-changer de mode de transmission avec un raccourci clavier (détection de la parole, seuil, appuyer pour parler (PTT))

-désactiver la liste des serveurs publics (qui banissent les gens qui viennent dire coucou donc inutiles en 2019)

-Renommer les utilisateurs

Ce tuto est inutile si vous êtes déjà passé sous Debian 10 où il suffit de faire un:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install mumble

ou si vous avez ubuntu, aucquel cas vous pouvez suivre le tuto pour installer un ppa launchpad.net en ajoutant le ppa de mumble

Nous allons utiliser ce .deb donné par le projet mumble pour ubuntu xenial, deux dépendances non disponibles sur les dépôts de debian 9 seront nécessaires:

libssl1.0.0 et libprotobuf9v5

nous allons donc les récupérer et les installer, ouvrez un terminal dans votre répertoire utilisateur (/home/votrepseudo)

wget http://security.debian.org/debian-security/pool/updates/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u12_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/p/protobuf/libprotobuf9v5_2.6.1-1.3_amd64.deb
wget https://launchpad.net/~mumble/+archive/ubuntu/release/+files/mumble_1.3.0-1~ppa1~xenial1_amd64.deb
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u12_amd64.deb
sudo dpkg -i libprotobuf9v5_2.6.1-1.3_amd64.deb
sudo dpkg -i mumble_1.3.0-1~ppa1~xenial1_amd64.deb

 #si vous rencontrez des erreurs dans l'installation du genre 
#Dépaquetage de mumble (1.3.0~git20190125.440b173+dfsg-2) ...
#dpkg: des problèmes de dépendances empêchent la configuration de mumble :

#ou

#dpkg: erreur de traitement du paquet mumble (--install) :
#problèmes de dépendances - laissé non configuré

#venez poster sur le forum ou sur IRC

#vous êtes aussi invités à changer les liens vers les .deb si des versions plus récentes et compatibles paraissent

Vous pouvez adapter le tuto en cas de nouvelle mise à jour en récupérant le .deb sur cette page: https://launchpad.net/~mumble/+archive/ubuntu/release/+packages

Ce tuto fait appel à un petit hack et il est conseillé de désinstaller ces trois paquets dès que la version désirée sera disponible sous votre système d'exploitation ou de faire une mise à niveau si il est obsolète car aucune mise à jour automatique ne les prendra en compte ce qui peut amener à des failles de sécurité.

Ce tuto a été préparé avec une debian 9 modifiée, DFLinux le 3/12/2019 avec les paquets suivants:

Il a été testé avec succès sous:

 

Sources:

https://packages.debian.org/fr/jessie/libssl1.0.0

https://github.com/rethinkdb/rethinkdb/issues/6228

https://www.mumble.info/blog/mumble-1.3.0-release-announcement/

https://www.mumble.info/downloads/

Next Post

Previous Post

Leave a Reply

© 2020 Journal du Nazmi

Theme by Anders Norén